Tagged: error

Foobar 0.9.5.3 0

Foobar 0.9.5.3

Yesterday updated my foobar from 0.9.5.1 to 0.9.5.3, and most of my main plugin that I’ve used become…unusable (incompatible). It doesn’t take long for me to revert back to foobar 0.9.5.1. The list of...

Safari 3 for Windows 2

Safari 3 for Windows

I read a lot of reviews about Safari’s Window version and most of them is not positive enough. Well it’s expected because the browser is in its beta phase (or alpha maybe). I also...